Changelog

Cara Update Widget

Summary

Sejak SDK terbaru Megahubs (0.6.0) sudah tidak lagi memerlukan pergantian versi secara manual.

Jika Anda masih ingin menggunakan versi lama untuk beberapa alasan, Anda dapat melakukan peningkatan versi SDK dengan cara yang cukup mudah hanya dengan mengganti versi dari potongan kode (snippet), seperti berikut:

Snippet Lama (v0.3.0):

1
2
3
4
5
    ...
    !function(a,b,c){var d=a.createElement(b),e=a.getElementById("mp-snippet");
    d.async=!0,d.id=c,d.src="https://mpwidget.s3.amazonaws.com/dist/v0.3.0/jssdk.min.js",
    e.parentNode.insertBefore(d,e)}(document,"script","mp-widget");
    </script>;

Snippet Baru (v0.5.0):

1
2
3
4
5
    ...
    !function(a,b,c){var d=a.createElement(b),e=a.getElementById("mp-snippet");
    d.async=!0,d.id=c,d.src="https://mpwidget.s3.amazonaws.com/dist/v0.5.0/jssdk.min.js",
    e.parentNode.insertBefore(d,e)}(document,"script","mp-widget");
    </script>;

Perhatikan pada line https://mpwidget.s3.amazonaws.com/dist/v0.5.0/jssdk.min.js , Anda tinggal mengganti versi rilis SDK dari v0.3.0 ke v0.5.0 & pastikan anda menggunakan versi rilis sesuai dengan yang tertera di halaman ini.

Perhatian!!

Perlu di ketahui, setiap versi rilis membawa perubahan dan konfigurasi yang mungkin tidak terdapat di versi yang lain. Pastikan Anda membaca "Changelog" untuk detail versi.


v0.6.0 / 2017 May Update

  • (New) Refactoring SDK
  • (New) Fix some performance & network issue
  • (New) Persistent Snippet! (no need for manual update)
  • (Deprecated) iFrame capability
  • (Fix) Minor Bug
  • (Fix) Some Parameter Issue

v0.5.0 - New Module

  • (New) Module Listrik
  • (New) Module Games
  • (Fix) Minor Bug

v0.4.0 - Compability Fix

  • (New) Support Android & iOS embedded web
  • (Fix) Browser Compability

v0.3.3 - Initial Public Release

  • Module Pulsa
  • API
  • etc.